Odd error after moving to 0.39

Need help with fSpamList? Post here! (DO NOT post removal requests here)

Moderator: fspamlist

User avatar
TeraS
Posts: 43
Joined: Thu Apr 16, 2009 2:35 pm
Gender: Female
Area Of Expertise: Just starting out...
experience: N00b...I know a lil bit
PC time: More than 4 hours a day
Contact:

Odd error after moving to 0.39

Postby TeraS » Mon Nov 16, 2009 6:02 pm

I have no idea what this is trying to tell me....

Code: Select all

Warning: include(/home/xxxxxxx/yyyyyyy/succubus.net/forum/check_spammers/Check_Spammers/view_spammers.php/functions.php) [function.include]: failed to open stream: Not a directory in /home/xxxxxxx/yyyyyyy/succubus.net/forum/check_spammers/Check_Spammers/view_spammers.php on line 12

Warning: include() [function.include]: Failed opening '/home/xxxxxxx/yyyyyyy/succubus.net/forum/check_spammers/Check_Spammers/view_spammers.php/functions.php' for inclusion (include_path='.:/usr/local/php5/lib/php:/usr/local/lib/php') in /home/xxxxxxx/yyyyyyy/succubus.net/forum/check_spammers/Check_Spammers/view_spammers.php on line 12


The xxxx's and yyyy's are to cover some information but are the same in each line above...

Any ideas?

Thankies!!


Tera
Thank you for calling TeraS, Queen of the Succubi... Please wait and she will be with you shortly...

User avatar
MysteryFCM
Site Admin
Site Admin
Posts: 3721
Joined: Sun May 15, 2005 12:42 pm
Location: Newcastle, UK
Contact:

Re: Odd error after moving to 0.39

Postby MysteryFCM » Tue Nov 17, 2009 3:03 am

Sorry for taking so long. Can you open view_spammers.php and change;

Code: Select all

include(__FILE__.'/functions.php');


To;

Code: Select all

$sMyPath = dirname(__FILE__).'/';
include($sMyPath."functions.php");
Regards

Steven Burn
I.T. Mate / hpHosts
it-mate.co.uk / hosts-file.net

Keeping it FREE!

User avatar
TeraS
Posts: 43
Joined: Thu Apr 16, 2009 2:35 pm
Gender: Female
Area Of Expertise: Just starting out...
experience: N00b...I know a lil bit
PC time: More than 4 hours a day
Contact:

Re: Odd error after moving to 0.39

Postby TeraS » Tue Nov 17, 2009 5:04 pm

MysteryFCM wrote:Sorry for taking so long. Can you open view_spammers.php and change;

Code: Select all

include(__FILE__.'/functions.php');


To;

Code: Select all

$sMyPath = dirname(__FILE__).'/';
include($sMyPath."functions.php");



Doing so gives a fatal error:

Code: Select all

Fatal error: Cannot redeclare isurlonline() (previously declared in /home/xxxxxxx/yyyyyyy/succubus.net/forum/check_spammers/Check_Spammers/functions.php:20) in /home/xxxxxxx/yyyyyyy/succubus.net/forum/check_spammers/Check_Spammers/functions.php on line 39


Sorry!


Tera
Thank you for calling TeraS, Queen of the Succubi... Please wait and she will be with you shortly...

User avatar
MysteryFCM
Site Admin
Site Admin
Posts: 3721
Joined: Sun May 15, 2005 12:42 pm
Location: Newcastle, UK
Contact:

Re: Odd error after moving to 0.39

Postby MysteryFCM » Tue Nov 17, 2009 5:08 pm

That's certainly a bit wierd. I've just released v0.40 which includes this fix and didn't notice that error.

The error indicates it's including functions.php twice, which it definately shouldn't be doing. Gimme a sec and I'll see if I can reproduce it :)
Regards

Steven Burn
I.T. Mate / hpHosts
it-mate.co.uk / hosts-file.net

Keeping it FREE!

User avatar
MysteryFCM
Site Admin
Site Admin
Posts: 3721
Joined: Sun May 15, 2005 12:42 pm
Location: Newcastle, UK
Contact:

Re: Odd error after moving to 0.39

Postby MysteryFCM » Tue Nov 17, 2009 5:13 pm

I'm sorry to say, I have reproduced it :( my apologies for that. The attached will fix it for you :)

It's got me curious now though as it previously demanded that the include() function be present in all files that used the functions.php file, regardless of where they were used themselves.

I'll get this tested to make sure the view_spammers.php and view_spammers_mail.php files still work properly without this declaration, and get v0.41 released asap :)
Attachments
view_spammers.zip
(4.7 KiB) Downloaded 234 times
Regards

Steven Burn
I.T. Mate / hpHosts
it-mate.co.uk / hosts-file.net

Keeping it FREE!

User avatar
MysteryFCM
Site Admin
Site Admin
Posts: 3721
Joined: Sun May 15, 2005 12:42 pm
Location: Newcastle, UK
Contact:

Re: Odd error after moving to 0.39

Postby MysteryFCM » Tue Nov 17, 2009 5:37 pm

Tested and released v0.41 :)

http://hphosts.blogspot.com/2009/11/spa ... -v041.html

Thanks again for bringing these to my attention, and sorry you had to go through this :(
Attachments
check_spammers.zip
SBST v0.41
(45.57 KiB) Downloaded 233 times
Regards

Steven Burn
I.T. Mate / hpHosts
it-mate.co.uk / hosts-file.net

Keeping it FREE!

User avatar
TeraS
Posts: 43
Joined: Thu Apr 16, 2009 2:35 pm
Gender: Female
Area Of Expertise: Just starting out...
experience: N00b...I know a lil bit
PC time: More than 4 hours a day
Contact:

Re: Odd error after moving to 0.39

Postby TeraS » Tue Nov 17, 2009 6:27 pm

<snugs>

I'd rather help in some small way to your work than do nothing...

<huggles>

Thankies again!!


Tera
Thank you for calling TeraS, Queen of the Succubi... Please wait and she will be with you shortly...

User avatar
MysteryFCM
Site Admin
Site Admin
Posts: 3721
Joined: Sun May 15, 2005 12:42 pm
Location: Newcastle, UK
Contact:

Re: Odd error after moving to 0.39

Postby MysteryFCM » Tue Nov 17, 2009 6:30 pm

hehe :)
Regards

Steven Burn
I.T. Mate / hpHosts
it-mate.co.uk / hosts-file.net

Keeping it FREE!

User avatar
TeraS
Posts: 43
Joined: Thu Apr 16, 2009 2:35 pm
Gender: Female
Area Of Expertise: Just starting out...
experience: N00b...I know a lil bit
PC time: More than 4 hours a day
Contact:

Re: Odd error after moving to 0.39

Postby TeraS » Tue Nov 17, 2009 6:31 pm

And the error has disappeared!

Thankies again!!


Tera
Thank you for calling TeraS, Queen of the Succubi... Please wait and she will be with you shortly...

User avatar
MysteryFCM
Site Admin
Site Admin
Posts: 3721
Joined: Sun May 15, 2005 12:42 pm
Location: Newcastle, UK
Contact:

Re: Odd error after moving to 0.39

Postby MysteryFCM » Tue Nov 17, 2009 7:11 pm

hehe my pleasure :)
Regards

Steven Burn
I.T. Mate / hpHosts
it-mate.co.uk / hosts-file.net

Keeping it FREE!


Return to “Help and Support”

Who is online

Users browsing this forum: No registered users and 1 guest